Combinaison fonction SI/ET/OU [Résolu]

Postez ici vos questions de niveau intermédiaire (p. ex. fonctions simples ou avec arguments, gestion des données, mise en forme conditionnelle, etc.)
EMDO
Messages : 2
Inscription : Lun Déc 10, 2018 10:18 am

Combinaison fonction SI/ET/OU [Résolu]

Message par EMDO » Lun Déc 10, 2018 10:31 am

Bonjour,

Je bloque sur des combinaison de fonction SI/ET/OU
J'ai mis un fichier d'exemple en PJ.
Il s'agit d'un extrait d'un plan d'action où je veux suivre les lignes du fichier où des retards sur la réalisation des actions sont détectés.

Il y a 3 colonnes :
- Date planifiée
- Date re-planifiée
- Date de clôture

J'ai une 4ème colonne où je souhaiterais faire apparaître :
1 - si l'action est en retard
2 - si l'action n'est pas en retard

L'action ligne doit apparaître à 1 si :
- la date planifiée est < à la date du jour ET date re-planifiée est vide
- la date planifiée est < à la date du jour ET date re-planifiée est < à la date du jour

L'action doit apparaître à 0 si :
- la date de clôture est renseignée
- la date planifiée est < à la date du jour MAIS date re-planifiée > date du jour
- la date planifiée est < à la date du jour ET/OU date re-planifiée est < à la date du jour MAIS date de clôture est renseignée

Il y a un peu trop de conditions pour moi.
Si vous aviez des techniques à me donner pour arriver à constituer une formule qui convienne.....Merci d'avance!

Emilie
Pièces jointes
Essai retard.7z
(14.19 Kio) Téléchargé 96 fois

EnzoAdmin
Site Admin
Messages : 24
Inscription : Dim Sep 16, 2018 8:09 am

Re: Combinaison fonction SI/ET/OU

Message par EnzoAdmin » Mar Déc 11, 2018 7:33 am

Bonjour et bienvenue sur notre forum.
Effectivement il y a plusieurs conditions à respecter. Il s'agit avant tout de placer les différentes conditions par ordre de priorité, c'est à dire d'éviter qu'une condition en occulte une autre, en sachant qu'excel va tester les conditions dans l'ordre trouvé dans la formule.
Je vais me pencher sur ce cas, qui pourra intéresser aussi d'autres personnes et tâcher de vous proposer une solution au plus vite.

Cordialement
Enzo

EnzoAdmin
Site Admin
Messages : 24
Inscription : Dim Sep 16, 2018 8:09 am

Re: Combinaison fonction SI/ET/OU

Message par EnzoAdmin » Mar Déc 11, 2018 8:11 am

Voici une solution qui me semble remplir toutes les conditions

=SI(ET(A2="";B2="";C2="");"";SI(C2<>0;"Clotûré";SI(A2>=AUJOURDHUI();"NON";SI(ET(A2<AUJOURDHUI();B2="");"OUI";SI(B2<AUJOURDHUI();"OUI";"NON")))))

Voir aussi fichier joint
Solution Essai retard.zip
(10.97 Kio) Téléchargé 105 fois
Cordialement

Enzo

EMDO
Messages : 2
Inscription : Lun Déc 10, 2018 10:18 am

Re: Combinaison fonction SI/ET/OU

Message par EMDO » Mar Déc 11, 2018 1:41 pm

Merci beaucoup, j'avais essayer différentes choses sans succès et là ça paraît simple et compréhensible et c'est exactement ce que je souhaitais obtenir!!

Merci!

Répondre