Home
L'interface
Le ruban
Les fichiers d'Excel
Les Feuilles de calcul
Les formules
Blog

 

Les Formules dans Excel 2010

 


Les formules constituent l'élément clé dans l'utilisation d'un tableur. Pour une utilisation optimale d'Excel il faut respecter quelques règles de base:

 


 

Depuis la version 2007 le formules ont leur propre ruban qui contient toutes les options et fonctions relatives aux calcules de tout genres:

 

 

Mais avant d'explorer ce ruban, voici un bref rappel de comment créer des formules simples dans excel,

 

 

Comment créer des formules simples:

 

Pour effectuer des formules correctement veuillez suivre les 5 points

 

1.   Sélectionnez la cellule qui doit recevoir le résultat (Formule)

 

2.   Pour indiquer à Excel qu'il s'agit d'une formule il faut commencer la saisie par le signe = ou +. Voici des exemples typiques de formules : =(D3+D4) ; =SOMME(D2:D6) ; =(D6/5)+50

 

3.   Dans une formule vous pouvez utiliser des références de cellules ou des constantes (chiffres). L'utilisation de références rend les formules dynamiques, c. à d. le résultat se met à jour automatiquement dès qu'on change le contenu des cellules représentées dans la formule. L'utilisation de références permet aussi la recopie de formules pour le calcul d'autres données.

 

3.1.      Pour éviter des erreurs dans les résultats il faut respecter quelques règles mathématiques :
La priorité des opérations dans la formule : Excel calcule les opérations dans l'ordre de priorité suivant :

a) les opérations entre parenthèses
b) Calculs exponentiels
c) Les multiplications et les divisions
d) Les additions et les soustractions

Pour illustrer ces règles de priorité voici un exemple :

1200 Personnes achètent des billets pour le cinéma à 15 €. Pour chaque billet il faut additionner une taxe de 1.50 €. Quelle est la recette totale ?

Voici la formule correcte:
=(15+1.5)*1200

 

Exemple illustré :

La formule se trouve dans la cellule B8. Pour que le calcul soit correct il faut placer l'addition des cellules B5 et B6 (prix + Taxe) entre parenthèses. Excel calcule ainsi d'abord le contenu de la parenthèse et multiplie le résultat avec la cellule B4 (nombre de personnes).

 

4.   Valider la formule avec la touche "Enter" ou le bouton

 

 

5.   Vérifier si les bonnes cellules et opérateurs ont été utilisés.

 

 


Les Messages d’erreur

 

Certaines erreurs dans les formules peuvent engendrer des messages d'erreur. Voici la liste des messages et leurs explications:

 

FRANCAIS

ANGLAIS

EXPLICATION

#VALEUR!

#VALUE!

Dans la formule il y a une valeur non numérique (ex texte)

#NOM?

#NAME?

La formule contient un nom qu'Excel ne connaît pas

#DIV/0

#DIV/0

Division par zéro

#REF

#REF

Une référence dans la formule a été supprimée

#N/A

#N/A

La valeur demandée (chiffre ou texte) n'est pas disponible